We have upgraded the servers administered by us to the latest OpenSSL version. This was done as soon as the operating systems released an updated package.

Please note, if you manage your own own server, we recommend you to upgrade your servers OpenSSL library immediately.

Since we can not be absolutely sure that the vulnerability has not been exploited, we recommend our customers to make sure to change the passwords used our service.

Additional information about the vulnerability:

https://www.cert.fi/varoitukset/2014/varoitus-2014-01.html
http://heartbleed.com/

10.04.2014